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Specifications 

System Specifications 

 

Model Name NeuroMotive 

Power Requirements 
120/240 VAC 60 Hz, 8.0 Amps maximum load, 

UPS backup power available for up to 5 minutes. 

Serviceable Fuses 5 x 20mm, 250V, 1.6A, Slow Blow 

Compliance 
Standards 

IEC 60601-1, IEC 60601-1-2, IEC 60601-2-26, 
CSA listed 

Type of Protection Class I (Amplifier Power Supply) 

Degree of Protection 
Type CF Applied Part (Amplifier and Patient Cable 

Assembly) 

Mode of Operation Continuous 

Water Ingress 
Protection 

Ordinary Equipment, not fluid resistant, IP20 

Operating 
Environment 

10˚C to 40˚C, 5 to 95% R.H.(non-condensing) 

Storage 
Environment 

-20˚C to 50˚C, 5 to 100% R.H.(non-condensing) 
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Camera Specifications 

NeuroMotive currently supports the Firefly MV and OptiTrack V100:R2 

Firefly MV (B&W or Color) 

Resolution 752x480 at 60 FPS • 320x240 at 112 FPS 

Frame Rate 60, 112 FPS  

Input / Output USB 2.0 

Synchronization Software and External Trigger 

Lens Mount 
CS-Mount (5mm C-mount adapter included) • 

M12 microlense mount 

 

 
 

OptiTrack V100:R2 

IR light 850nm from 26 LEDs 

Resolution 640 X 480 

Frame Rate 25, 50, 100 FPS 

Input / Output USB 2.0 

Synchronization Software and External Trigger 

Lens Mount M12 lens mount 
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What This Manual Covers 

This manual covers the technical specifications and instructions for use of the Blackrock 
NeuroMotive System (Neuromotive). Neuromotive is a video recording/playback system with 
optional movement and behavior tracking capabilities.  It allows for synchronized biopotential 
recording and behavioral tracking of animal subjects. 

Introduction 

System Description 

The NeuroMotive System is designed to record and process video frames from a single 
camera.  The system works in conjunction with the Cerebus or the CerePlex Direct data 
acquisition systems on a dedicated or shared Host PC. Each frame is time-stamped and 
synchronized with the neural, analog and digital experimental data recorded with the 
Cerebus or CerePlex Direct. 

NeuroMotive playback relies on nPlayServer, an offline experiment playback tool that 
simulates real time data acquisition and video/animal tracking playback. 

The system is capable of sampling video at a rate of up to 100 fps with hardware 
synchronization from a Cerebus Neural Signal Processor. The effective maximum frame 
rate depends on the camera used as well as the acquisition system.  

Minimum System Requirements 

• Microsoft Windows 7 or higher Professional Edition 64-bit 

• Intel Quad Core or Core i5 CPU with at least 4 processor threads (i.e., ‘cores’) 
running at 3.2 GHz or faster 

• 8 GB of RAM 

• 1 TB 6Gbit/s SATA III HDD 

• 1 Gigabit Ethernet adapter 

• 1 USB 2.0 port  
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System Schematic 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1 NeuroMotive system schematic 

 

Packaging Contents 

• NeuroMotive Camera 

• NeuroMotive Manual and Software 

• Cables and Connectors 

• USB Software Licensing Dongle 

• USB synchronization hub (if using the IR Camera) 

• Reflective Tracking Material (if using the IR Camera) 
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Setup 

Licensing Dongle 

NeuroMotive also requires connection of the NeuroMotive Software Licensing Dongle to 
an available USB port. 

NeuroMotive Camera Options 

The NeuroMotive system has multiple options for the camera type.  The camera-
NeuroMotive PC interface depends on the camera type and synchronization method. If 
using software synchronization or if not using NeuroMotive in conjunction with a neural 
data acquisition system, then simply connect the camera to the PC. If using hardware 
synchronization, then use the following guidelines: 

FireFly MV 

The Firefly MV camera has three lens rings that can be twisted see Figure 2.  
The arrows denote individual lens rings.  Starting with the leftmost ring and 
moving right the first ring is for zooming in on the scene, the second ring is the 
focus for reducing blur and the third ring is the aperture. 

 

 

Figure 2 – The Firefly MV camera. 
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Connect the camera via USB to the PC and connect the camera to either a digital 
output port on the NSP or the NeuroMotive Synchronization port on the CerePlex 
Direct using the supplied hardware synchronization cable. 

 

   

 

Figure 3 - NeuroMotive System Connected to an CerePlex Direct Using a Color Camera 
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OptiTrack V100:R2 

Connect the camera to the USB Sync Hub included with NeuroMotive System IR 
Camera and connect the Hub via USB to the NeuroMotive PC and via the 
included BNC Cable to either a Digital Output port on the NSP or the 
NeuroMotive camera port on the rear of the CerePlex Direct. Here is an example 
of the synchronization hub and its connections to the IR Camera, NeuroMotive 
PC and a Digital Output port on the NSP: 

 

Figure 4 - IR Camera Hardware Synchronization Hub with Connections to NSP 

NeuroMotive Software 

Installation 

Run the NeuroMotive Windows Installer.msi and other included installers from the 
supplied CD and follow the instructions.  

NeuroMotive Main Window 

To run the NeuroMotive application click on the NeuroMotive icon on the desktop, 
alternatively click on the Start Menu and select the program under All 
Programs\Blackrock Microsystems.  The main window consists of the video display, the 
toolbar, 5 dock bars and a status bar at the bottom.  The five dock bars are for Playback 
Control, Camera Control, Image-capture Status, Regions of Interest (ROI), and Tracking 
Marker Definition.  The ROI and Marker dock bars come with the optional tracking 
feature.  The NeuroMotive application operates in two modes, Camera and Playback.  If 
a camera is connected and active when NeuroMotive is opened, the Camera mode is 
automatically chosen and the image from the camera is shown on the Video Display.  By 
setting the Video Source under Video Display in the advanced options menu (Tools-
>Options) to the camera connected to the NeuroMotive PC the mode is also switched to 
Camera mode.  When a file is opened or the NeuroMotive software is opened while 
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nPlayServer is running, the mode is switched to the Playback mode. Playback mode is 
also accessible by setting the Video Source to File in the advanced options menu. 

 

Figure 5 - NeuroMotive Main Window 

NeuroMotive File Types 

NeuroMotive produces the different file types listed below: 

Configuration Files 

.xml  

NeuroMotive creates and updates an options.xml file in the Experiment 
Directory that holds the current configuration settings for NeuroMotive. If 
this file is found on startup, NeuroMotive loads the configuration 
automatically. If no configuration is found, a new options.xml, is populated 
with the default settings. Note that this file is constantly updated as 
settings are changed. 

.ncf  

This file is created and named concurrently with each video file. It can be 
considered a ‘snapshot’ of the options.xml file because it saves the 
configuration of NeuroMotive as it was when recording began. This file 
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can then be loaded using File->Open Experiment to reset NeuroMotive to 
match the time of recording. 

Video Files 

Based on the video recording options selected, one of the following file types will 
be used: 

.mpg  

These contain MPEG2 video files, most video players can play these. 
See Advanced Options for more details. 

.mp4  

These contain H.264 video files, most current video players can play 
these. See Advanced Options for more details. 

File Menu  

• Open Video: This allows loading of a previously recorded video file. 

• Close Video: Close the opened video file. Also sets NeuroMotive to Camera 
Mode if it is in Playback Mode. 

• Open Experiment: This loads the file type .ncf which contains saved experiment 
settings such as tracking regions of interest, event regions of interest, marker 
definitions, filenames, etc. 

• Hardware standby and close: Places the neural data acquisition device (NSP 
or CerePlex Direct) in “Standby” mode. File storage should be stopped prior to 
this. In “Standby”, neural data acquisition stops and an NSP must be in “Standby” 
to update its firmware. 

• Hardware shutdown and close: Closes NeuroMotive and stops the neural data 
acquisition device. Shutting down using this method requires manually turning off 
the device’s power switch. 

• Exit: This exits NeuroMotive and leaves the DAQ in its current state. 

View Menu 

• Tool Bar: Shows or Hides the Toolbar. 

• Status Bar: Shows or Hides the Status bar. 

• Object Shape and Direction: Shows or Hides the lines connecting the tracking 

markers and the arrow indicating the direction the tracking object is moving.  

• Trajectory: Shows or Hides the recorded path of where the object has been. 
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• View Markers: Shows or Hides the Tracking Markers on the Video Display. 

• View Tracking Regions of Interest: Shows or Hides the Tracking ROI on the 

Video Display. 

• View Event Regions of Interest: Shows or Hides the Event ROI on the Video 

Display. 

• View Always on Top: This prevents the NeuroMotive window from being 

covered by other windows. 

View Processed Image  

Threshold Markers 

The video display area shows the frames after having been processed to only 
show what falls within the threshold ranges of color and/or brightness selected 
for the Tracking Markers as well as expected size of the Markers. This view is 
useful for tuning NeuroMotive to track particular Tracking Markers. For a more 
detailed explanation of this please see section Threshold on page 30. 

Threshold Marker 1 

The video display area shows the frames after having been processed to show 
only what falls within the threshold range of color and/or brightness for the first 
Tracking Marker as well as expected size of the Marker.  

Threshold Marker 2 

The video display area shows the frames after having been processed to show 
only what falls within the threshold range of color and/or brightness for the 
second Tracking Marker as well as expected size of the Marker. 

Threshold Marker 3 

The video display area shows the frames after having been processed to show 
only what falls within the threshold range of color and/or brightness for the third 
Tracking Marker as well as expected size of the Marker. 

Preprocessed 

The video display area shows the frames with only a luminance or hue scale 
(greyscale). This is also useful for setting the Tracking Markers as it can 
determine which colors or lights stand out or if adjustment to the ambient lighting 
is needed. 

Tools Menu 

• Rewind: Step back through the video file for the number of frames specified. 
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• Step: Step forward through the video file for the number of frames specified. 

• Play/Pause: Play/Pause the open video file. 

• Stop: Stop playing the open file. Note that upon pressing play the video file will 

restart from the beginning. 

• Replay: Set NeuroMotive to restart the video file from the beginning when it 

reaches the end of the playback in a repeated loop.   

• Record and Stop 

o Track: Start and stop tracking features if they are available.  

o Note: To track while in Playback mode, enable Tracking in the options. 

Go to Tools->Options->Video Display->Video Source (select File, then 

‘more’)->Enable Tracker. 

o Comment: If NeuroMotive is connected to NSP or nPlayServer, 

Comment allows a comment to be entered or ‘injected’ into the data 

stream. 

o Predefined Comment: Under Tools->Options up to 5 comments can be 

stored by NeuroMotive that can then be automatically injected into the 

data stream anytime. They automatically map to the keyboard shortcuts 

Ctrl+FN where N is the number of the comment (1-5). 

o Zoom In: Zooms the video display into the center.  

o Zoom Out: Zooms the video display out. 

o Zoom Original: Zooms the video display to the default state. 

o Options: See Advanced Options on page 26. 

 

• Window: Shows and Hides the various dock bars available in NeuroMotive in its 

different modes with and without optional features. 

• Capture Status: Shows or Hides the Capture Status dock bar. 

• Play Back Control: Shows or Hides the Play Back Control dock bar. 

• Camera Control:  Shows or Hides the Camera Control dock bar. 

• Markers Definition: Shows or Hides the Markers Definition dock bar. 

• Regions of Interest: Shows or Hides the Regions of Interest dock bar. 

• Help 

• About NeuroMotive: Displays information about the versions of NeuroMotive 

and the Hardware Library. Also lists the currently available capabilities of 

NeuroMotive as determined by the software licensing dongle. 
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Video Display 

The video display shows the rendered image from the camera in Camera mode, and the 
file in Playback mode.  With the optional tracking feature, the video display also shows 
the tracking and event regions of interest, the tracking markers, the direction and recent 
path of the object, and, optionally, the elapsed time and frame number.  The mouse and 
mouse wheel can be used to zoom in or out on different areas of the video display in 
multiple ways:  

• Click on the video display then rotate the mouse wheel to zoom in and out.  

• Select a rectangle on the display by depressing the left mouse button and 
dragging. Releasing the left mouse button will zoom in the display to the selected 
rectangle.  

• Double-clicking will zoom back out to the default state. 

Toolbar 

The toolbar visibility is controlled by the Toolbar option in the view menu.  The buttons 

displayed on the toolbar are dependent on the mode NeuroMotive is in.  

 

Camera Mode 

Open Video for Playback 
Start Recording 
Stop Recording 
Start/Stop Tracking - Tracking feature only 
Show/Hide the Markers Definition Dock Bar - Tracking feature only 
Show/Hide the Regions of Interest Edit Dock Bar 
Show/Hide the Capture Status Dock Bar 
Show/Hide the Camera Control Dock Bar 
Zoom In 
Zoom Out 
Zoom Original 
Show/Hide the Object Shape and Direction while Tracking 
Show/Hide the Object Trajectory 
Show/Hide the Tracking Markers 
Show/Hide the Event Regions of Interest 
Show/Hide the Tracking Regions of Interest 
Render the View Using the Threshold Image - Tracking feature only 
Render the View Using the Preprocessed Image - Tracking feature only 
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Playback Mode 

Open Video for Playback 
Close the Currently Opened Video 
Step Back a Specified Number of Frames (Rewind) 
Step Forward a Specified Number of Frames 
Toggle Automatic Replay of the Video File 
Stop Playback  
Start/Stop Tracking - Tracking feature only 
Show/Hide the Markers Definition Dock Bar - Tracking feature only 
Show/Hide the Regions of Interest Edit Dock Bar 
Show/Hide the Capture Status Dock Bar 
Show/Hide the Play Back Control Dock Bar 
Zoom In 
Zoom Out 
Zoom Original 
Show/Hide the Object Shape and Direction while Tracking 
Show/Hide the Object Trajectory 
Show/Hide the Tracking Markers 
Show/Hide the Event Regions of Interest 
Show/Hide the Tracking Regions of Interest 
Render the View Using the Threshold Image - Tracking feature only 
Render the View Using the Preprocessed Image - Tracking feature only 

 
Note: that any buttons involving tracking will only appear if the tracking option 
has been purchased and enabled offline tracking is selected in the options: 
Tools->Options->Video Display->Video Source (select File, then ‘more’)->Enable 
Tracker. 

 

Camera Control Dock Bar 

The Camera Control Dock Bar is displayed in Camera mode.  It controls recording, 
filename and some adjustable camera properties:  

• Exposure - This slider adjusts the amount of light coming through the camera 
lens, note that this is less responsive in low-light conditions.  

• Intensity - This slider is for infrared only to control the amount of light emitted by 
the IR camera LEDs.  

• Automatic Gain Control (AGC) - This can be toggled to have the camera 
automatically adjust the image if it is too bright or dark.  

• Brightness - This slider for the Color camera controls how bright or dark the 
image appears after the frame has been captured.  

• Gamma Correction - This automatically tries to adjust for low-light conditions 
with the Color camera but brightening the whole image. 

• Note: The Auto checkbox is meant to have the NeuroMotive software 
determine the optimal values. 
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Figure 6 - NeuroMotive Camera Control Dock Bar for Color (left) and IR (right) Cameras 

Playback Control Dock Bar 

The Playback Control Dock Bar is displayed in Playback mode.  The dock bar contains 
options to control the playback of a video recording. 

 

• Play – Toggles video playback between 
play and pause. 

• Replay - Toggles automatic restart of 
the video once the end of playback is 
reached. 

• Stop - Stops playback and restarts the 
video from the beginning upon pressing 
Play.  

• Step - Plays the number of frames 
specified in the Step Samples edit box 
and then pauses. 

• Rewind - Rewinds the number of frames 
specified in the Step Samples edit box 
and then pauses. 

• Play From/Current/Play To - Specifies the beginning and end of playback in the 
video file. This can be set using the upper slider controls. Current can be set with 
the lower slider control. 

Figure 7 - Playback Control Dock Bar 
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Capture Status Dock Bar 

The Capture Status Dock Bar shows recording and processing statistics in Camera 
mode and playback statistics in Playback mode.  There are 5 status groups.  Clicking on 
the left arrow to expands/collapses each group. Please note that when NeuroMotive is 
initially installed only a limited number of statistics are displayed. To display the other 
statistics toggle the checkboxes under Display Statistics in Tools->Options->General. 

 

General 

• Time Elapsed:  Time of the 

current frame. If playing or 

recording, this is the time of the 

frame in the file. Otherwise, it is 

the time since the beginning of 

capturing frames. 

• File Size:  Size of the open file 

either being recorded or played 

back. 

Frame Rates 

• Fps: fps (frames per second) is 

the average number of frames 

rendered per second. 

• Rendered: Number of frames 

rendered in the elapsed time. 

• Captured: Number of frames 

captured from the camera or file 

in the elapsed time.  

Note: This number can get out of 

sync with Rendered if the frame is frozen to define Tracking Markers, but 

no data is actually lost. 

• Encoded: Number of frames encoded or compressed in the elapsed 

time. 

• Decoded: Number of frames decoded or decompressed in the elapsed 

time (used for playback). 

• Recorded: Number of frames recorded to a file in the elapsed time. 

 

 

Figure 8 - Capture Status Dock Bar 
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Average Times (ms) 

• Render: The average time in milliseconds it takes to render a frame in 

the video display. 

• Encode: The average time in milliseconds it takes to encode a frame to 

some video format. 

• Color: The average time in milliseconds it takes to convert the colors of a 

frame to RGB values from some other color format. 

• Decode: The average time in milliseconds it takes to decode a frame 

from some video format. 

• Record: The average time in milliseconds it takes to record a frame to a 

file. 

• Capture: The average time in milliseconds it takes to capture a frame 

from the camera. 

Tracking 

• Markers: The current number of markers NeuroMotive can see in the 

tracking area. 

• Objects: The current number of objects NeuroMotive is tracking. 

ROI 

• Events: The number of events (entering/exiting an Event Region of 

Interest) that have occurred in the elapsed time. 

Regions of Interest Dock Bar 

The Regions of Interest Dock Bar is available with the optional tracking feature.  Up to 
four tracking Regions of Interest can be defined.  Tracking Regions of Interest define the 
area where tracking occurs.  Any movement outside the union of the Tracking Regions 
of Interest is ignored.   

Up to four Event Regions of Interest can be defined.  Events are generated when the 
moving object enters and exits an Event Region of Interest.  Events are automatically 
injected into the data stream with the name of the Event Region of Interest and an 
enter/exit status that includes in the coordinates of the entrance/exit of the region. 
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To define Tracking Regions of Interest 
select the tracking radio button.  To define 
Event Regions of Interest select the event 
radio button.  The four edit controls at the 
left contain the names of each of the four 
Regions of Interest.  To define a Region of 
Interest, click a Define button, and draw a 
rectangle on the video display while holding 
down the primary mouse button.  To 
change the position of a Region of Interest, 
press the corresponding delete button and 
follow the steps above to re-define the 
Region of Interest. 

  

 

 

Figure 9 - Regions of Interest Dock Bar 
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Markers Definition Dock Bar 

The Markers Definition Dock Bar is available with 
the optional tracking feature.  Markers are located 
on the moving object and for tracking to be 
effective markers must be distinguishable from 
the rest of the frame.  The controls on the 
Markers Definition Dock Bar define the markers 
and how the NeuroMotive software needs to 
process the frames in order to see the markers. 
This enables the tracking software to find the 
markers and thus optimize tracking.  Markers can 
be distinguished by luminance, color or both.  The 
following options can be found in the Markers 
Definition Dock Bar: 

Threshold  

This selects what scale NeuroMotive uses 
in evaluating what portions of the image 
should be able to be tracked. 

Luminance  

This option works well for grey scale images, particularly those using an IR 
camera. NeuroMotive gives each pixel in the image a brightness value based on 
a grey scale of the image. The associated Luminance threshold slider can then 
be set so that only those pixels at or above the defined marker’s brightness will 
be detected and possible to track. Luminance also includes an Invert option that 
will flip the brightness value of every pixel so that dark objects may be tracked 
against a light background using the luminance threshold.  

Color   

NeuroMotive uses a Hue, Lightness, and Saturation (HLS) scale to give each 
pixel a hue value corresponding to a particular color. The associated threshold 
slider for a selected color can then be set so that only those pixels within the 
threshold range in either direction on the hue wheel (see Figure ) will be 
detected and possible to track. This option works well for tracking colors in 
images that are not glossy. Note also that for non-color images NeuroMotive 
converts the pixels to a greyscale (luminance) value. 

LED   

This option combines the luminance and color thresholds and is best used with 
color images where the markers are distinctly bright and colored compared to the 
rest of the image, like perhaps when using LEDs for tracking. This option works 
by applying the color threshold first and then removing all pixels below the 
luminance threshold. 

Figure 10 - Markers Definition Dock Bar 
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• Freeze/Unfreeze - Freezes the camera image, useful for defining 

markers on a moving object. Click again to unfreeze the image. 

• Define Head/Define - Activates the selection process for defining a 

marker by selecting it. Note that the head must always be defined, but the 

other markers are optional. Clicking these buttons also freezes the image 

automatically.  

• Note: When defining markers it is recommended that the whole process 

be performed twice without deleting any markers. This is because the 

optimizations performed by NeuroMotive to identify the markers that are 

selected is adaptive and will better average the values of the pixels of the 

markers once it has an idea of the size and shape of the markers which 

only occurs after defining markers the first time. 

• Delete - Removes a marker definition and all its information. 

• Color - Displays the marker color as NeuroMotive currently understands 

it.  Colors can be selected manually by selecting the color indicator and 

adjusting to the desired color.  Redefining the marker without deleting the 

previous color is better as NeuroMotive’s marker tracking and definition is 

adaptive. 

• Color Threshold - For each marker defined the range in hue from the 

indicated color over which NeuroMotive will detect (see Figure ). This can 

also be used for non-color images; the range is just on a grey scale. 

• Luminance Threshold - For all markers defined the minimum brightness 

pixels must have in order to be detected. 

• Radius - Markers will be detected as semi-circular blobs of pixels that 

can change size and shape as the tracked object is moved. This sets a 

minimum and maximum radius of pixels that NeuroMotive should detect 

as a marker and track.  The radius is only used for eliminating potential 

markers after other filtering has occurred and there are more markers 

than are currently defined. 

• Low Pass Filter - This is explained in more detail in section Low Pass 

Filter on page 30, but it essentially averages the values of pixel blocks so 

that the image has less noise and smaller elements that might be 

detected as markers may be removed. This can be set to average 5x5 

pixel blocks, 3x3 pixel blocks or none. 

• Morph Open - Stands for Morphological Opening Filter, this is also 

explained in more detail in section  

• Morphological Opening Filter (Morph Open) on page 30. It essentially 

removes smaller blobs of a 3- or 5-pixel radius. 
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• Morph Dilate - Stands for Morphological Dilation Filter, this is explained 

in more detail in section Morphological Dilation Filter (Morph Dilate) on 

page 31. It essentially blows up the blobs NeuroMotive sees so they are 

bigger and possible merged with other nearby blobs; which helps in 

instances where a marker is detected as multiple blobs. This affects blobs 

of a 3- or 5-pixel radius. 

Marker Preparation 

In order for NeuroMotive to successfully track objects, it is important to pick 
effective markers and ensure appropriate lighting. For markers using the Color 
camera ensure colors are as distinctive from each other and the object being 
tracked as possible. Biocompatible neon glow paint is a good option. LEDs are 
another good option as they impart unique color and luminance allowing less 
ideal lighting conditions. For the IR camera, special reflective material is provided 
that works specifically with the IR camera to ease tracking configuration. 
Concerning lighting, the lighter and the more diffuse and ambient that light is the 
better that lighting will be in helping to eliminate reflective spots that can disrupt 
the camera’s ability to see the markers. LEDs used in low light is very effective.  
The IR markers included with IR camera systems are useful at demonstrating the 
capabilities of IR tracking. 

Marker Definition 

To begin marker definition, freeze the camera image or stop playback, by clicking 
Freeze or any define button. This begins definition mode. In definition mode the 
Freeze button text changes to Unfreeze and markers can be defined by clicking 
on a define button; then clicking on the corresponding marker on the video 
display. Definition mode ends when Unfreeze is clicked.  Zoom is allowed when 
the image is frozen to assist in selecting the marker. 

Marker Color 

To the right of the Define buttons are the Marker Color Boxes. If Luminance is 
selected as the threshold function, a greyscale luminance of the marker is shown 
in the Marker Color Box. If Color or LED is selected, the marker color is shown in 
the Marker Color Box. When a marker is defined, the Marker Color Box is 
automatically filled with the color or greyscale value of the marker. Because of 
variations in lighting and camera function, the marker color may not appear 
correct. This can be fixed by clicking on the Marker Color Box and displaying a 
Marker Color dialog, allowing the marker color to be changed.  The process for 
color selection averages the pixel color at the clicked location and nearby pixel 
colors to determine the color of the marker.  Defining a marker more than once 
increases accuracy by providing a larger sample size for the average, helping to 
filter noise. 
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Marker Threshold 

To the right of the 
Marker Color Boxes 
are the Threshold 
Sliders. The numerical 
value of each 
threshold will display 
when the mouse 
cursor hovers over a 
slider. 

Color and luminance 
captured by the 
camera change with 
ambient and diffuse 
light present, and with 
the area in the field of 
vision occupied by the 
moving object. Because of 
this, the marker color and 
luminance may occupy a 
range of values. The 
Threshold sliders specify this 
range. If Luminance is 
selected, the Threshold slider 
for luminance is accessible. If 
Color is selected, the 
Threshold sliders for color 
can be adjusted. And if LED 
is selected, both the Threshold sliders for color and luminance are available.  

The Color Threshold slider specifies the degrees of tolerance in each direction of 
the color wheel from the marker color (Figure ). All color values greater than the 
marker color plus the color threshold, and less than the marker color minus the 
color threshold are ignored by the software. Same holds on the greyscale if the 
image is non-color. 

The Luminance Threshold slider specifies the tolerance on the greyscale (0 – 
255) from the selected marker luminance (Figure ). All luminance values less 
than the marker luminance threshold are ignored by the tracker. 

The LED Luminance slider value specifies the darkest value the tracker should 
consider. All luminance values less than the LED Threshold are ignored by the 
tracker. And all those greater are maximized in brightness. 

When using the Color Threshold sliders it is helpful to remember that the further 
to the right a slider is set, the greater the range of colors that will be deemed to 
constitute the color value of the associated marker. When using the Luminance 
Threshold, the further to the left the slider is set the less light is required to be 
above the threshold. This leads to the possibility of false positives and the marker 

Figure 11 - Color, LED and Luminance Thresholds 
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jumping around. When adjusting the sliders it is suggested to use the Threshold 
view of NeuroMotive (View->Processed Image->Threshold Markers) to pinpoint 
when the Tracking Markers appear.  Using threshold view shows blobs that have 
been identified as potential markers.  They should be varying shades of grey and 
white against a black backdrop as shown in Figure . Adjust the threshold sliders 
until only the markers are visible. 

The sliders under camera control provide an additional way to change the 
amount of light reaching the camera. The exposure slider determines the amount 
of light reaching the camera, note that the exposure function is less responsive in 
low light conditions. Selecting the Automatic Gain Control checkbox or Gamma 
Correction checkbox provides a brighter image for low light environments. The 
intensity slider adjusts the amount of light emitted by the IR camera and the 
brightness slider will increase the light values of every pixel in an image. 
Selecting the Auto checkbox tries to adjust the exposure, brightness and/or 
intensity for the current lighting conditions. The best conditions for tracking have 
good ambient lighting and use colors at opposing ends of the color spectrum in 
relation to the object to be tracked. The IR camera works well in low light 
conditions but presents the possibility of reflections being tracked. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 12 - Threshold View of Three Tracking Markers  
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Marker Size 

Size is another attribute that helps the software locate markers. Objects and their 
tracking markers may change in apparent size as they move around in the 
camera’s field of vision. To minimize apparent changes in size, center the 
camera directly above the tracking area.  

The Radius slider specifies the maximum and minimum value in pixels that the 
tracker will recognize for the radius of a marker. Make sure View Markers is 
toggled on to help see how adjusting the sliders affects both the marker size and 
what’s viewed as a potential marker. 

 

 

 

 

Figure 13 - Camera Position and Its Effect on an Object's Perceived Size 

Marker Filters 

There are three filters that operate on the image before the tracker determines 
the marker position. 

The Low Pass Filter 

The ow pass filter removes noise in the greyscale and hue scale by 
averaging the values of pixels together in blocks (3 x 3 pixels or 5 x 5 
pixels), blurring the image slightly. This creates more uniform spots of 
color/luminance and a smoother gradient.  The 3x3 low pass filter 
averages a square neighborhood of one pixel away from the middle pixel 
of interest.  The 5x5 low pass filter averages a square neighborhood of 
two pixels away from the middle pixel of interest. 
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The Morphological Opening Filter (Morph Open)  

The Morphological Opening Filter filters out spots whose size in pixels is 
below a certain threshold, for instance 3 pixels by 3 pixels, and might 
otherwise be considered markers. This is a two-step process where all 
spots are reduced and any that remain are then returned to their original 
size thus removing spots below a pixel threshold. 

The Morphological Dilation Filter (Morph Dilate)  

The dilation filter is applied last and it solidifies marker images that might 
have holes in them and thus be interpreted as two distinct markers. It 
does this by expanding the remaining spots by a number of pixels (e.g., 3 
x 3 adds 3 pixels on each axis). This way if a marker’s image was seen 
as two spots, those spots might now overlap and make one marker 
image. 

Note: If the markers are small, they may be eliminated by the Low Pass 
Filter or the Morphological Opening Filter. In the case where markers are 
small use the smaller filter numbers or no filters.  
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Technical note on Frame Processing 

When defining markers, it helps to understand how the tracking and image processing is 
implemented. When tracking is enabled, each frame goes through the following 7 steps 
to determine the marker positions. 

Convert to Single Channel 

The Red Green Blue (RGB) values taken in by the camera are converted to 
single channel representations of Hue and Luminance. Hue is in the form of an 
angle on the color wheel (see Figure ) with Red equal to the angle 0 and 360. 
Luminance is a greyscale with values from 0 to 255. If color is selected, then the 
Hue representation is used; if luminance is selected then the Luminance 
representation is used; and if LED is selected then both representations are 
used. If the camera is non-color, then the values are already in a single channel 
representation. 

Low Pass Filter 

The low pass filter removes small variations or noise by averaging pixels with 
their neighbors.  This is like going over the frame with a blurry brush. The Low 
Pass Filter specifies the number of pixels to average (i.e. the size of the blurry 
brush). View->Processed Image->Preprocessed displays the frame after the low 
pass filter. 

Threshold 

In this step, everything that is not in the specified Luminance and/or Color 
threshold ranges is discarded. After this step, the frame has only two colors: the 
dark background color and the lighter foreground color. Anything that may be a 
marker is specified in the foreground color and each tracked marker gets its own 
shade (this includes any false positives which will show up in the same shade as 
the marker they are mimicking). 

Morphological Opening Filter (Morph Open)  

The area of each possible marker after the threshold has been applied is 
shrunken by a set number of pixels (e.g., 3 x 3 pixels) and enlarged again by that 
set amount. If a marker is smaller than the filter, it will shrink into nonexistence. 
When the area is enlarged again, the possible marker will be gone.  This erosion 
removes possible markers that are too small to consider. This step executes 
quickly, but it is important to note that in using the morphological opening filter, 
sensitivity is lost to changes in the actual marker that is being tracked as the 
object moves around. 
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Morphological Dilation Filter (Morph Dilate) 

This grows the radius of the remaining possible markers by the number of pixels 
specified (e.g., 5 x 5 adds 5 pixels on each axis of a visible marker), filling in 
potential gaps that may make a single marker appear to be two or more markers. 
View->Processed Image->Threshold Markers displays the frame after the 
Morphological Dilation filter has been applied. Since this filter automatically 
expands all visible markers following the Morphological Opening filter it also 
brings back some sensitivity lost by that filter. 

Radius evaluation 

The radii, measured in pixels, of the remaining possible markers are evaluated. If 
the radius is not within the range specified by the Radius slider, the possible 
marker is discarded. Having View->View Markers toggled will display the 
possible markers that NeuroMotive is seeing (indicated by red ‘+’ symbols). 

Proximity elimination  

When a marker is first defined, its position in the tracking area is saved.  In this 
step, the possible markers that remain after all of the above filtering are 
evaluated for their proximity to the saved position. The marker that has the 
closest position to the initial position is deemed to be the actual marker and the 
rest of the possible markers are discarded. And if more than one marker meets 
this criteria then the marker closest to what NeuroMotive predicts to be the next 
position (based on previous movements) is chosen as the correct marker. The 
position of this select marker is then saved as the new position to compare 
against.  

When using multiple tracking markers this procedure is slightly altered to take 
advantage of the fact that the positions of the markers relative to one another 
(the tracking ‘shape’) should remain mostly unchanged. When multiple markers 
are defined their positions relative to one another (their shape) are recorded 
along with their absolute positions in the tracking area. When evaluating markers, 
all the sets of markers in proximity to the recorded positions that meet the shape 
criteria are then reviewed and the closest set of markers with the correct shape is 
selected. If more than one set meets this criteria then the set that most closely 
matches the prediction NeuroMotive has made on what the new position should 
be (based upon past movement) is selected. The new positions of the markers 
are then recorded to compare against. Additionally, this prediction allows 
NeuroMotive to address object occlusion while tracking. Although occlusion of a 
marker may result in the tracking shape being pinched as NeuroMotive tries to 
predict the position of the occluded marker.  

At this point it is also important to note how NeuroMotive determines an object’s 
position in relation to the markers being used for tracking. First, an object’s 
position is determined by the number of defined markers. For a single marker the 
object position is the position of that marker. For two markers the object position 
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is based on the marker that is not the head marker. For three markers the object 
position is the midpoint between the markers that are not the head marker. 

Status Bar 

The status bar displays short descriptions about the tools available in NeuroMotive. By 
placing the mouse cursor over the various buttons and boxes a brief description of their 
function will appear in the status bar. In addition, on the right side of the bar are two 
status buttons. 

 

 
Figure 14 - NeuroMotive Status Buttons 

 

The first button handles NeuroMotive’s connection status. When the button is clicked, 
NeuroMotive will attempt to connect to a device including nPlayServer, an NSP, or a 
CerePlex Direct Host PC. If NeuroMotive is connected to a device, then information 
about the device and NeuroMotive’s connection will display: 

 

 
Figure 15 - NeuroMotive Stand-alone (no Central) Connection Status with an NSP 

 

This button will also change to reflect what kind of device NeuroMotive is connected to, 
here it’s connected to nPlayServer for file playback: 

 

 
Figure 16 - NeuroMotive Connection Status with nPlayServer 

 

The second button displays information about the current camera connected to and in 
use by NeuroMotive. This information includes resolution, frame rate, network latency 
between the camera and currently connected neural data acquisition device and more. 
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Figure 17 - Camera Statuses for Color and IR cameras in NeuroMotive 
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Advanced Options 

The advanced options allow specification of the behavior of many parts of the 
NeuroMotive software. To access these options, go to Tools->Options. 

Experiment Tab 

 
Figure 18 - Experiment Tab 

 

The Experiment tab allows specification of where files related to NeuroMotive will 
be stored as well as a free form comment to be saved in NeuroMotive’s options 
file and any recordings made during the current session (specifically the 
recording’s .ncf file and .nev file if using Central in conjunction with NeuroMotive). 

Experiment Directory  

Specifies where NeuroMotive stores its options file (options.xml) and 
where it will look for its options file on startup. The options file contains 
the most recent settings for NeuroMotive and is used to carryover 
NeuroMotive’s state from session to session. 

Playback Directory  

Specifies the default location NeuroMotive will search in for video files. 
This is especially important when NeuroMotive needs to synchronize with 
a neural data file as it will automatically load the appropriate video file 
when it’s in the correct directory. 

Recording Directory  

Specifies the location to which NeuroMotive will save video files and their 
associated .ncf file. Note that the .ncf file contains all the settings of 
NeuroMotive at the time of a recording; it is akin to a snapshot of the 
options file that can be loaded to return NeuroMotive to a previous state. 
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Freeform Comment Box  

The large white box under the Video Location section is a comment area 
where comments can be entered to be saved in NeuroMotive’s options 
file and in a video file’s associated .ncf file and .nev file if using 
NeuroMotive with Cerebus Central software. 

 

Video Display Tab  

 

Figure 19 - Video Display Tab 

 

The Video Display tab configures the video source NeuroMotive uses for 
retrieving visual data and how it is displayed. 

Video Source  

This section specifies the source of video data and options available for 
that source. There are currently six sources for video data. 

▪ None - No video source. 

▪ File - NeuroMotive plays a compatible video file. This is 

automatically selected on loading a video file. It includes the 

following options: 

▪ File - Either a specific file may be selected (NeuroMotive will load 

all available files it finds in the Playback directory) or Auto can be 

selected. Auto is meant for use with neural data playback as it will 
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attempt to load the video file with the same name as the files 

being played by nPlayServer. 

▪ File Reader - Refers to how files are loaded for reading. 

▪ File Mapping - Loads the whole video file into memory, it provides 

fast playback, but limits video file size to 2 GB. 

▪ Direct - Read file directly from the hard drive; might be slower, but 

there are no limits to file size, this is the default. 

Enable Tracker  

If the Tracking Option has been purchased for NeuroMotive then this will 
allow utilization of all the tracking features available in NeuroMotive while 
playing back a video file. 

Camera: Test  

This option allows trying out NeuroMotive and all its features even if there 
is not a camera attached to the NeuroMotive PC. It has one option: 

Capture frame rate  

Sets the frame rate the test camera emulates to see how NeuroMotive 
handles under differing camera loads. 

Camera: FlyCapture 

This selects Firefly MV color camera that can be supplied with 
NeuroMotive. The following options can be set for it: 

Embedded statistics  

This shows or hides various statistics in the video frame itself. Currently 
only two statistics display: Time Elapsed and Frame Number. 

HQ Linear color processing  

Determines which algorithm is used to convert the color information from 
the camera’s format to RGB format. This occurs before any image 
processing is done for tracking and recording. The HQ Linear regression 
algorithm takes more time but produces a cleaner image while the IPP 
edge sensing algorithm (if the box is unchecked) is very quick, but leaves 
a noisy image, especially around the edges. How the image is colored 
can end up affecting how well tracking will proceed. The default is to use 
the HQ Linear regression algorithm.  

Target capture frame rate (fps)   

Sets the frame rate of the camera. The higher the rate, the more 
resources (time, memory, CPU, etc.) will be used, but the picture will be 
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sharper and resolution with respect to neural data will be higher (e.g., 
fewer samples per frame). 

Trigger method  

This determines what drives the camera’s shutter to capture frames and 
how accurately frames are synced to neural data. The following options 
are available: 

Isochronous (software)  

The camera drives itself and synchronization with neural data is 
estimated in the software based on network packet times. This method 
must handle for variable network latencies and multiple timers so it is the 
least accurate but is always available. The frame rate may be specified 
for this method. 

External  

This option is a hardware synchronization that allows for non-Blackrock 
equipment to drive the camera. It includes the additional option Trigger 
Polarity which allows selection of whether the shutter triggers on a high or 
low voltage. With this method any synchronization with video data must 
be handled by the non-Blackrock equipment as it determines when a 
frame is taken. The frame rate must also be specified. 

NSP Digital Out  

This option is a hardware synchronization method for use with the NSP. 
Using the supplied hardware synchronization cable, the NSP will drive the 
camera from one of the digital output ports on the NSP with active high 
polarity. This option allows selection of any of the four digital output ports 
using the Digital Output Channel dropdown menu. This method is far 
more accurate in synchronizing video and neural data as the number of 
timers is reduced and network latency can be ignored. This method does 
not require setting the frame rate. 

CerePlex  

This is another hardware synchronization option that is for use with the 
CerePlex Direct. It includes the additional option of setting whether the 
camera is triggered on high or low voltage with Trigger Polarity. Like the 
other hardware synchronization options, it is far more accurate for 
matching up video and neural data. This method does not require setting 
the frame rate. 

Camera: OptiTrack  

This selects the OptiTrack V100:R2 infrared camera that can be supplied 
with NeuroMotive. The following options can be set for it: 
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Embedded statistics  

This shows or hides various statistics in the video frame itself. Currently 
only two statistics display: Time Elapsed and Frame Number. 

Capture frame rate (fps)  

Sets the frame rate of the camera. The higher the rate, the more 
resources (time, memory, CPU, etc.) will be used, but the picture will be 
sharper and resolution with respect to neural data will be higher (e.g., 
fewer samples per frame). Note: the OptiTrack camera may go up to 
100fps and requires a hardware sync (non-isochronous) and selecting 
‘100’ or manually enter ‘100’ into the Capture frame rate (fps) field. 

Trigger method  

This determines what drives the camera’s shutter to capture frames and 
how accurately frames are synced to neural data. The following options 
are available: 

Isochronous (software)  

The camera drives itself and synchronization with neural data is 
estimated in the software based on network packet times. This method 
must handle for variable network latencies and multiple timers so it is the 
least accurate but is always available. The frame rate may be specified 
for this method. 

External  

This option is a hardware synchronization that allows for non-Blackrock 
equipment to drive the camera. It includes the additional option Trigger 
Polarity which allows selection of if the shutter triggers on a high or low 
voltage. With this method any synchronization with video data must be 
handled by the non-Blackrock equipment as it determines when a frame 
is taken. The frame rate must also be specified. 

NSP Digital Out  

This option is a hardware synchronization method for use with the NSP. 
Using the supplied hardware synchronization cable, the NSP will drive the 
camera from one of the digital output ports on the NSP with active high 
polarity. This option allows selection of any of the four digital output ports 
using the Digital Output Channel dropdown menu. This method is far 
more accurate in synchronizing video and neural data as the number of 
timers is reduced and network latency can be ignored. 

CerePlex  

This is another hardware synchronization option that is for use with the 
CerePlex Direct. It includes the additional option of setting whether the 
camera is triggered on high or low voltage with Trigger Polarity. Like the 
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other hardware synchronization options, it is far more accurate for 
matching up video and neural data. This method does not require setting 
the frame rate. 

Camera: RTSP  

This selects the use of any camera this uses the Real Time Streaming 
Protocol (RTSP) over a network. The following options can be set for it: 

Profile  

This determines what controls are available for the networked camera. 
Currently there are two options: Auto will auto detect the camera and a 
list of available functions; Sanyo refers to a special robotic camera that 
can be remotely operated by NeuroMotive. 

URL  

The network address of the RTSP camera. 

Username  

Credentials to access the camera. 

Password  

Credentials to access the camera. Includes the option to save the 
password.  

Video Renderer 

This section specifies the method by which the video data is displayed onscreen 
and options available for the method. Currently only OSG OpenGL is available 
for rendering and it has the additional option for setting the maximum target 
displayed frame rate. Choose Auto to have NeuroMotive select the appropriate 
rate to display at or set it to 30fps. 

Video Decoder 

This section specifies options for decoding video data from a file or networked 
camera. NeuroMotive will automatically determine the correct decoder to use 
while the other options help to adjust how many resources the computer should 
give to the decoder to enhance performance. 

Buffer Size (Frames)   

This affects memory on the computer and determines how big of a buffer 
to give NeuroMotive for storing frames to be decoded. More frames 
generally mean less stutter or chance of a loss of frames. 
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Threads   

This affects the CPU. The more threads used for decoding the faster it 
will be, but at the cost of other portions of NeuroMotive being slowed or 
losing data or even other programs slowing down. This can be set to Auto 
and NeuroMotive will determine the needed thread count to keep up with 
the incoming video data. 

Reorder Decoded Frames  

This forces NeuroMotive to decode and render frames in order. This 
should always be selected, especially if playing back or recording in sync 
with neural data as each frame is synchronized with specific sample data. 

Video Recording Tab  

 
Figure 20 - Video Recording Tab 

 

The Video Recording tab specifies codecs that can be used for encoding video 
data as well as the file types for storing the data. There are also options for 
adjusting the quality and performance of the recording.  

Video Encoder 

This specifies the encoder for compressing the raw video data. There are 
three specific encoders currently available with an option for NeuroMotive 
to automatically select an encoder that will work. Each encoder has its 
own options and every encoder shares the following common options: 
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Buffer Size (Frames)  

Determines the number of frames that can be buffered at any one time. 
More frames mean more memory usage, but higher quality video and 
frame rate with less worry of frame loss. Generally, this option will not 
need to be adjusted unless recording high definition video. 

Threads  

Determines the number of threads created to handle encoding video data. 
Up to 4 can be created or NeuroMotive can automatically determine how 
many are needed to ensure proper encoding. More threads mean higher 
CPU usage and a possible slowdown for other programs or even portions 
of NeuroMotive, but higher quality video can be encoded.  

Bit Rate  

Specifies the file quality of the video file. The higher bit rate creates a 
higher quality video but also greater video file size and higher CPU usage 
to ensure the higher bit rate is all encoded. 

It is recommended to leave the encoder set to Auto in NeuroMotive as 
the software works very well at determining a suitable video file encoder. 
But the following other options do exist: 

H.264  

Most commonly used for encoding high definition video. Can currently 
encode to the video container (file format) MP4. It has the following 
options: 

Profile  

A set of capabilities set in the encoder that give a specific picture 
quality vs. performance need, NeuroMotive includes three of 
these. 

Base  

Low definition video, but highly robust against data loss. 
Primarily used for video conferencing it is also good for 
ensuring low frame drop. 

Main  

Used for standard-definition digital television broadcast. 
Clearer image, but at the cost of more resources needed to 
encode and a greater chance of data loss. 

High  

Used by the Blu-ray Disc storage format. High definition 
image, but very costly for computing resources and an 
even higher risk of data/frame loss. 
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I-Frame Interval  

The I-Frame is a key frame that does not depend on other frames 

in this encoding for information. Having a shorter I-Frame Interval 

means that the video file is more robust against corruption, is faster 

to seek through (fast forward, rewind, etc.) and should generally 

have a higher quality picture. A smaller interval, however, also 

means a larger file size. 

B-Frame Rate  

B-Frames are a type of frame that can look in both directions of a 

file during compression for portions of frames that do not change 

and so only need to be noted once in the video file, reducing file 

size or conversely allowing more detail to be stored in the same 

amount of space. The frame rate indicates how many B-Frames will 

be inserted between I-Frames and P-Frames (like B-Frames but 

can only look in one direction of a file during compression). The 

higher the rate, the better the compression-to-detail ratio of a file, 

but there is also more time needed during file seeking and less 

defense against corruption. A frame rate of 2 is considered 

sufficient. 

Reference Frames  

This values determines how many frames a B or P-Frame may 

search through looking for frame redundancies during 

compression. The higher the number of frames, the better the 

compression and lower file size/better quality. But in exchange 

decompression (playback and seeking) and compression times are 

increased and more memory will be needed upon playback for 

decompression.  

Slices  

During encoding (compression) a frame can be split into regions 

(slices) that can be searched for redundancies against the same 

regions in other frames. On a multi-core processor regions can be 

assigned to different cores and searched in parallel, greatly 

increasing compression speed. The tradeoff is that some 

redundancies may be missed because they merely shift to a 

different region (like in a panning shot), this loss results in a lower 

quality video. 
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ME Method  

The Motion Estimation Method contributes to reducing the size of 

the video and improving video quality in transmission by removing 

redundant information between frames during the encoding 

process. It is the most computationally intensive portion of encoding 

and thus has many algorithms that attempt to reduce this cost while 

maintaining quality. NeuroMotive currently supports 6 different 

algorithms with the H.264 encoding format that vary in quality vs. 

computational time required to perform. All include a threshold 

optimization and are as follows: 

2D Logarithmic Search  

This approach navigates a search area by evaluating five 

equally spaced points (blocks) in a cross shape that shrinks 

when the center candidate most closely matches the 

reference block (it is the best candidate) and shifts when it 

does not. This one is a good balance of speed and quality 

for encoding.  

Enhanced 2D Logarithmic Search  

This is an enhanced version of the above Logarithmic 

Search that expands the number of blocks evaluated at a 

time to nine but retains the same speed. A better-quality 

version of the Classic Logarithmic Search; this is the default 

method for encoding. 

EPZS Search  

The Enhanced Predictive Zonal Search (EPZS) algorithm is 

similar to the logarithmic searches, but it attempts to achieve 

the speed and precision of those searches while also trying 

to ensure that the entire search area is analyzed for the best 

candidate. By starting with a larger search area (1/4 of the 

entire search region), but using the same number of points, 

it trades off some precision for a better chance at finding the 

best global candidate. 

One-At-A-Time Search  

This algorithm first checks along the center x-axis of the 

search area for the best candidate point and then along the 

y-axis from that point. This is very fast and uncomplicated, 

but not necessarily accurate in finding the globally best 

block of pixels in a search area for motion estimation. 
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Logarithmic One-At-A-Time Search  

A logarithmic variation of the above search that starts by 

finding the best candidate point along the center x-axis in 

the search area and then the best candidate along the y-

axis starting from the x-axis point. This should be faster than 

the One-At-A-Time Search, but still as inaccurate. 

Square Search  

This search starts at the center of the search area and 

evaluates a 3 x 3 grid of points. If the center point is the best 

candidate the search is finished, otherwise the point that 

was the best candidate becomes the center point and the 

search continues. The speed of this search depends on the 

location of the block being searched for. The same goes for 

finding the best block in the search area. 

ME Split Mode  

This option indicates how finely frames can be divided up into 

discrete blocks for encoding. Smaller blocks allow for greater detail 

to be retained and often better file compression sizes, but 

compression/decompression will take longer as the encoding is 

much more complex. NeuroMotive supports three different split 

modes: 

16x16 Only  

Frames are divided into blocks that are 16x16 pixels. This 

allows for the fastest encoding/decoding, but image quality 

may not be the best and file sizes may not be as efficient 

they could be. 

16x16, 16x8, 8x16, 8x8  

This option allows the encoder to use any of the 

aforementioned block sizes (in pixels) to divide up frames in 

order to maximize compression size while retaining as high 

an image quality as possible. This option provides a good 

balance between encoding/decoding speed and video 

quality. 

8x8, 8x4, 4x8, 4x4  

This option adds four additional options for block size to the 

ones previously mentioned allowing for greater image 

quality than the other options at the cost of a longer 

encoding/decoding time and possibly larger file size. 
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ME Search X  

This option, along with ME Search Y, dictates how large the search 

radius is for the motion estimation algorithms. A larger value allows 

for a more encompassing search and thus better-quality video, but 

the algorithm will take longer and so will overall encoding. Currently 

this option is preset to a value tested to work well with all the 

algorithms.  

ME Search Y  

This option is the same as ME Search X but dictates the range 

along the y-axis as opposed to the x-axis. It is currently preset to a 

value determined to work well with all the algorithms included in 

NeuroMotive. 

Quality vs. Speed  

During the encoding and motion estimation processes multiple 

steps can be taken when analyzing frames for compression. The 

more steps taken, the greater the quality of the final video file, but 

encoding also takes longer (this can lead to loss of data if the 

encoding buffer overruns). The greater the value is set for this 

option the more steps will be performed and the longer encoding 

will take to complete.  

Entropy Coding Mode  

Determines the method by which the final data is 

encoded/compressed, the current choices are: 

CAVLC  

Context-Adaptive Variable-Length Coding. This is the faster 

option, but it is 5-15% less efficient at compression which 

leads to a slightly lower quality video. 

CABAC  

Context-Adaptive Binary Arithmetic Coding. More efficient 

and better-quality video, but encoding/decoding (playback, 

file seek, etc.) can take longer. Generally, this is the better 

option, but if speed is an issue or if the profile is set to Base 

then CAVLC is recommended.  

MPEG2  

A predecessor of MPEG4 that is not as efficient at compression as 

MPEG4 but should be even more widely included on devices as a 

playable format. This can currently encode to the video container 

(file format) MPEG2PS. It includes the following options: 
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GOP Size  

‘Group of Pictures’ size. This refers to how many frames are 

grouped together at a time for encoding. Every group 

consists of an I-Frame and a series of P and B-Frames 

meaning this option can be viewed as indicating the 

frequency of I-Frames. A greater GOP Size gives greater 

compression/quality, but longer decoding/seek time. 

IP Distance  

This determines the maximum number of frames allowed 

between reference frames, I and P-Frames. Another way of 

looking at this is that it determines the frequency of B-

Frames in a group of pictures. The greater the IP Distance 

selected, the better the compression/video quality, but the 

longer decoding/file seek time on playback. 

Video Container 

This specifies the container type for the video file, the file format. 
The formats available depend on the encoder used and it is 
recommended to leave this setting on Auto and have 
NeuroMotive select an appropriate format. All selections have the 
following common options: 

File  

This indicates how the filename will be selected. Auto will 

have NeuroMotive use whatever filename is specified by 

Central when recording in sync with Central. The other 

option listed will be the last file recorded or played back by 

NeuroMotive. Please note that during recording if another 

file in the recording directory has the same name as the file 

being recorded then NeuroMotive will automatically append 

a counter to the filename of the file being recorded to make 

it unique. Additionally, to combine files for a single recording 

connect the NeuroMotive PC and Central PC over a network 

independent of the NSP. Make the Central PC hard drive 

shared to allow copying to the NeuroMotive PC. 

Buffer Size (Frames)  

This sets the size of the buffer used by the muxer, a tool that 

combines all visual, audio, text and meta data of a video 

together into a single file. A larger buffer reduces the chance 

of losing data during recording, but also uses up more 

memory. Again, it is recommended to leave the container 

set to Auto in NeuroMotive as the software works very well 

at determining a suitable video file format. But the following 

other options do exist: 
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MP4  

A more recent file format; most newer/up-to-date video 

players will play this format and this format is designed to 

handle high definition audio and video (like Blu-Ray Disc 

quality). H.264 can encode to this format. 

MPEG2PS  

PS (Program Stream); this file format is the oldest, but also 

the most prolific. It is used primarily for video storage on 

reliable media formats like DVD. Because it is used for 

DVDs most video players should support it.  MPEG2 can 

encode to this format. 
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Video Tracking Tab 

 

Figure 21 - Video Tracking Tab 

The Video Tracking tab specifies different options about what to track and record. 
Note that the Tracking Option must be purchased in order to utilize this tab. 

Video Tracker 

This currently contains all the options available in NeuroMotive for 

setting what to track and record. The options are as follows: 

Tracker Dropdown  

Determines what to track, currently it can be set to track 

markers or nothing, thereby disabling tracking. 

Record Object Position  

Enables/disables the recording of an object’s position based 

on the tracking markers in an associated .nev file. If tracking 

a single marker then it will record that marker’s position as 

the object’s position. If tracking three markers, preferably 

with them placed in the shape of an isosceles triangle with 

the head as the top point, then NeuroMotive will track the 

markers that fit this shape and record the midpoint of the 

base of the triangle as the object’s position. 



 

Revision 2.00 / LB-0336 – NeuroMotive IFU 

© 2018 Blackrock Microsystems, LLC   

49 

Record Object Markers  

Enables/disables the recording of an object’s tracking 

markers in an associated .nev file. If the tracked object is 

found by NeuroMotive, the position of the markers in each 

frame can be recorded. This works best with three markers 

as their positions relative to one another are used by 

NeuroMotive to help keep track of them and the object. If 

only one marker is being tracked then this option behaves 

like the previous one. 

Record Markers Area Sizes  

Enables/disables the recording of the sizes of the areas of 

the markers being tracked, as perceived by NeuroMotive, in 

an associated .nev file. This may be useful for diagnostic 

purposes to see how well NeuroMotive is tracking the object 

or to troubleshoot any data inconsistencies. 

Record All Markers  

All items in the camera’s view that could be identified as 

markers have their position recorded with this enabled. If the 

object is found by NeuroMotive then its markers’ positions 

will be listed first. This option will supersede Record Object 

Markers. 
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General Tab 

 

Figure 22 - General Tab 

 

The General tab allows setting various behaviors of NeuroMotive: what warnings 
it gives, processing statistics, when it can record, etc. 

Warnings 

These are notices that NeuroMotive can relay about its state to help 

ensure recording, especially in sync with an NSP or CerePlex 

Direct, operates smoothly. The following warnings can be toggled: 

Instrument Network  

Warns if NeuroMotive is not connected to an instrument 

such as an NSP, CerePlex Direct or nPlayServer. This can 

appear on startup or if the instrument disconnects in the 

middle of operation. 

Remote Recording  

Warns if a remote device such as Central on another 

computer tries to trigger NeuroMotive to record and it is 

unable to do so. 

Recording Overload  

Warns if NeuroMotive is unable to keep up with recording 

and is dropping frames. 
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Recording Client  

Warns if the user is trying to run NeuroMotive and Central 

on the same computer and record with both, most 

computers will not be able to handle this load and data will 

be lost. 

Display Statistics 

These are various processing statistics that NeuroMotive can be 
toggled to display in the Capture Status window. 

Time  

Displays the time elapsed from startup, the start of recording 

or the end of recording. 

Frames Captured  

Displays the number of frames capture by the camera. 

Frame Number  

Displays the current number of the frames shown during file 

playback. 

Frames Rendered  

Displays the number of frames rendered by NeuroMotive, 

note that this number can be out of sync with Frames 

Captured if the picture has been frozen, but that does not 

indicate data loss. Data is lost if markers are being defined 

while recording. 

Frames Recorded  

Displays the number of frames recorded by NeuroMotive 

during recording. 

Track Objects  

Displays the number of objects NeuroMotive is currently 

tracking if the tracking option has been purchased with 

NeuroMotive. This number should be equal to one under 

ideal conditions. 

Frames Decoded  

Displays the number of frames decoded by NeuroMotive 

during playback or if using a networked camera. 

Avg. Render Time  

Displays the average time in milliseconds NeuroMotive 

takes to render a frame for display. 
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Avg. Recording Time  

Displays the average time in milliseconds NeuroMotive 

takes to record a frame. 

Avg. Decoding Time  

Displays the average time in milliseconds NeuroMotive 

takes to decode a frame during playback or from a 

networked camera.  

Avg. Encoding Time  

Displays the average time in milliseconds NeuroMotive 

takes to encode a frame during recording. 

Track Markers  

Displays the number of markers NeuroMotive is currently 

tracking if the tracking option has been purchased. This is 

the number of markers selected under ideal conditions. 

Frames Encoded  

Displays the number of frames encoded by NeuroMotive 

during recording. 

Avg. FPS  

Displays the average frames per second or frame rate 

NeuroMotive is capturing from the camera at. This value will 

be near the selected value, but it can oscillate around it. 

File Size  

Displays how large the file being recorded is currently in 

bytes. 

Avg. C. Conv Time  

Displays the average time is takes NeuroMotive to convert 

the color values of a frame from whatever the source format 

is to the format required by the renderer. This will be 

different for different files, cameras and renderers used with 

NeuroMotive. 

Avg. Capture Time  

Displays the average time in milliseconds that NeuroMotive 

waits for a frame from the connected camera. 

Track Events  

Displays the number of times a tracked object enters or exits 

a designated event area if the tracking option has been 

purchased with NeuroMotive. 
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Instrument 

These options dictate how NeuroMotive interacts with an 
instrument it is connected to on a network. Specifically, this refers 
to how it will behave when connected to Central. 

Record Offline  

This indicates if NeuroMotive is allowed to record when not 

connected to a device like the NSP or CerePlex Direct. In 

order to use tracking offline the Video Source must be set to 

File and Enable Offline Tracking must be checked. 

Automatic Playback  

This triggers if NeuroMotive will automatically set the Video 

Source on connection to an instrument. File if it connects to 

nPlayServer and the last camera used if it connects to the 

NSP or CerePlex Direct. 

Startup Connect  

Sets NeuroMotive to try and connect to an instrument upon 

startup. 

Slave Recording  

Determines if NeuroMotive can trigger recording when 

connected to Central remotely. If toggled then only Central 

can start recording for both, otherwise NeuroMotive or 

Central can begin recording. Warning: when recording is 

initiated by NeuroMotive a .nev file may be written in a 

location other than the experiment directory. 
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Comment 

This option allows determination of whether comments can be more than one line 
before being sent to the NSP and Central. If it’s not toggled then comments are 
sent as soon as ‘enter’ is pressed, otherwise ‘enter’ must be pressed twice in 
succession to send a comment. 

 

 

Figure 23 - Comments Tab 

 

This tab allows setting up to five single line preset comments that can be sent at 
any time by either navigating to Tools->Predefined Comment and selecting the 
comment or by pressing the associated shortcut keys listed next to each 
comment. 
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Marker Definition Example 

The following example shows how to use the Marker Definition Dock Bar to optimize tracking. 

This is also a good example of the type of controlled environment that facilitates optimal tracking. 

Color vs. Luminance 

Figure 24 shows a frame with three bright markers in a low light scene. 

 

 

Figure 24 - Three bright markers, in a low light scene - Color selected 

Color 

Zooming in, the markers appear to have a uniform and distinguishable pattern. We first 
try distinguishing the markers by color by selecting the Color Radio Button on the 
Markers Definition Dock Bar. 
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Figure 25 - Markers in Figure 24 enlarged 

 

Selecting View->Processed Image->Preprocessed, shows on the Video Display the 
captured frame after it has been converted to Single Channel (Hue in this case because 
Color is selected). All the pixels are represented by an angle on the color wheel, and the 
picture appears in greyscale. Because the light is low, the human eye cannot detect the 
sporadic occurrences of yellow in the frame. However, the computer can detect the 
yellow. The computer displays these detections by red + signs to indicate possible 
markers.  

 

 
Figure 26 - Single Channel or Hue Greyscale Image 

 

In the threshold image it is clear the abundance of yellow color results in many possible 
markers in the scene and false marker detection. Figure 28 zooms in on the incorrectly 
chosen markers. 
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Figure 27 - Threshold Image - Color selected 

 

 

 

Figure 28 - Incorrectly Chosen Markers 

LED 

Reconsidering the original image again, we notice the yellow markers are brighter than 
the background (a second discriminatory factor other than color), so LED tracking should 
produce the best results. Figure 29 shows the original image with LED selected 
(luminance = 63), both color thresholds set to 16, and a marker radius of 4-15. With 
these settings the yellow marker is clearly found. 
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Figure 29 - Three bright markers, in a low light scene – LED selected 

 

From the threshold image in Figure 30, it is clear why a yellow marker was found. There 
are no other areas with a comparable luminance in the frame.  

 

 
Figure 30 - Threshold Image – LED selected 
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Morphological Filtering 

Figure 36 zooms in on the markers from Figure 35. The two yellow markers are merged 
forming a single marker. In order to track 3 markers, the markers must appear distinct to 
the software. The yellow markers can be separated physically on the object in motion, or 
filtering can be used to try and make them separate. The following figures demonstrate 
how using and combining the filters can change the appearance of the markers as seen 
by NeuroMotive. 

  

 
Figure 31 - 5x5 Low Pass, 3x3 Morphological Opening, and 5x5 Morphological Dilation filters 

 

Figure 32 was created using a 5x5 Low Pass filter, 3x3 Morphological Opening filter, 
and a 5x5 Morphological Dilation filter. Compared to Figure 31 where the dilation is 
removed, we see the marker sizes in Figure 31 are smaller because morphological 
dilation increases the size of the markers. With the minimum radius set to 4 these 
markers are just barely acceptable. 
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Figure 32 - 5x5 Low Pass filter, 3x3 Morphological Opening filter, and no Dilation filter  

 

In Figure 33 the marker shape is affected because smaller noise around the markers is 
not removed with the morphological opening filter before dilation is applied. Because of 
this the noise is dilated as well and the markers get merged together.   

 

 
Figure 33 - 5x5 Low Pass, no Opening, and 5x5 Morphological Dilation filters 

 

Figure 34 shows the markers with a 5x5 Low Pass filter, no morphological opening filter, 
and no morphological dilation filter. Because there is no morphological opening filter the 
small noisy areas around the edges of the markers are not removed, but because there 
is also no morphological dilation filter they are not expanded and thus not merged either.  
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Figure 34 - 5x5 Low Pass filter, no Opening filter and no Dilation filter 

 

Figure 35 shows the markers with no low pass filter, no morphological opening filter, 
and no morphological dilation filter. As can be seen, this makes the marker shape 
appear jagged. There is a hole in one of the markers. And a minimum radius of 4 is no 
longer small enough to identify one of the markers resulting in the wrong direction being 
calculated.  In summary, if the markers are very small, both low pass filtering and a 
morphological opening filter may remove them. Also remember that a morphological 
opening filter takes into account the size of the markers, while low pass filtering takes 
the hue or luminance value of the neighboring pixels into account. 
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Figure 35 - no Low Pass filter, no Opening filter, and no Dilation filter 

Figure 36 shows the markers with a 5x5 Low Pass filter, 3x3 Morphological Opening 
filter, and 3x3 Morphological Dilation filter. With a smaller dilation filter (3x3), the markers 
do not merge and both separate yellow markers are found. 

 

 

 
Figure 36 - 5x5 Low Pass filter, 3x3 Morphological Opening filter, and 3x3 Morphological 

Dilation filter 
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Luminance 

Figure 37 shows the threshold image with the luminance threshold reduced from 63 to 
6. Three more spots pass the threshold filter (yellow circles); one of them even passed 
the marker radius filter. If we continue decreasing the LED luminance threshold, we will 
get the same result as if we only used the color threshold from before resulting in an 
abundance of false yellow markers being detected. 

 

  

 
Figure 37 - Luminance Threshold reduced from 63 to 6 

How To 

Using the Tracking Region of Interest to 

Eliminate Marker Reflection 

The following example has only one marker to track. The marker is a flashing LED with a 
cyan-green color. A flashing marker is suboptimal because the marker cannot be found 
in the frames where the flash is off causing the tracking to possibly jump around. Figure 
38 shows a frame with the flashing LED marker reflected on the right side of the glass 
enclosure. The reflection is eliminated by moving it outside the Tracking Region of 
Interest (the green rectangle). Only the areas within a Tracking Region of Interest are 
considered for tracking. 
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Figure 38 - Using the Tracking Region of Interest to Eliminate Reflection 

Select the Camera for Recording 

• Connect the Camera and the NeuroMotive Host PC with the included USB 
Cable. 

• Start NeuroMotive. 

• Go to Tools->Options. The Options Dialog will be displayed. 

• Select the Video Display tab. 

• Select the camera type in the Video Source Combo Box. 

• Click OK 

 

Record a Standalone Video  

• Start NeuroMotive and make sure the video camera is connected properly and 
selected (See above). The video display area should show images from the 
camera.  

• The Camera Control Dock Bar contains an edit box where the name of the file to 
record and the record and stop buttons for recording. 

• To specify the file locations navigate to Tools->Options and in the Options Dialog 
open the Experiment Tab. Using this tab allows specification of where video files 
will be saved (Recording directory), where NeuroMotive will default to for finding 
video files to playback (Playback directory) and where to save NeuroMotive 
settings (Experiment directory). 
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• Playback a Standalone Video 

• Start NeuroMotive. 

• Go to File->Open Video. 

• Type in the file name in the field or navigate to the video file in the dialog box that 
appears and click Open. 

• Click on Play. 

 

Record a Video with a Neural Recording 

A video file can be recorded in sync with neural data recorded using Central Software 
Suite.  Before starting to record with NeuroMotive, Central must be running on a Host 
PC, connected to an NSP or CerePlex Direct and the File application should be open 
and setup properly, ready to record.   

• Start NeuroMotive and make sure the video camera is connected properly and 
selected. 

• Open the File application in Central (Refer to the Cerebus manual).   

• Make sure File Specification is 2.3 or higher and the File application is 
synchronized with NeuroMotive (in the File application go to View->Options-
>Sync with NeuroMotive (if present), for further details refer to the Cerebus 
manual).  

• A NeuroMotive indicator should appear on File application dialog. 

 

 
Figure 39 - File Application Connected to NeuroMotive 

 

• In order to use NPlayServer, be sure to record continuous data. 

• Start neural recording through the File application. 

• Video recording will start automatically on the NeuroMotive PC. Note that 
NeuroMotive will duplicate the filename specified in the File application. 
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Additionally, if the filename chosen is already being used by another video file in 
the recording directory then NeuroMotive will automatically append an 
incrementing counter to the filename to create a unique filename. 

• During recording of files, NeuroMotive will continue recording when Central is 
paused. 
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Playback a Video with a Neural Recording 

A previously recorded video file can be played back in sync with a previously recorded 
neural data file. Note that the files needed to have been recorded in sync. 

• Copy the neural data recording (.nev, .ns*, .ccf files of the same name as the 
video file) to the NeuroMotive  video playback directory. 

• Verify the video filename is the same as the neural data files (with a different 
extension). 

• Start nPlayServer. 

• Open Central. 

• Open NeuroMotive. 

• If you are viewing tracking, enable offline tracking in Tools->Options->Video 
Display->Video Source->File and then load the .ncf configuration file with the 
same filename as the video filename using File->Open Experiment. You may 
need to adjust the threshold method and/or the low pass, morph open, and 
morph dilate filters. 

• Browse and select the recorded neural data files in the 
nPlay File Control GUI (select any file from the dropdown 
box that matches the desired filename). 

• NeuroMotive should automatically open the appropriate 
video file.  If not, go to File->Open Video. 

• Type in the file name in the field or navigate to it and then 
click Open. 

• Use the playback controls (pause, stop, step, etc.) in 
NeuroMotive, nPlay will synchronize playback accordingly. 
Using the controls in nPlay causes uncertain behavior.  
NeuroMotive provides accurate controls and the nPlay 
controls do not reflect the state of the system. 

• The Central Software Suite applications automatically are 
synchronized with nPlay, and thus with the video. 

• While playing back very long files, the video may pause. To remedy this, press 
pause and then play. 

 
  

Figure 40 - Selecting a 

Neural Data File in the 

nPlay File Control GUI 
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Support 

Blackrock is proud to offer comprehensive remote support and troubleshooting. Contact out 

support team for additional information or help with any of our products. 

 

www.blackrockmicro.com/technical-support 

support@blackrockmicro.com 

+1(801) 582-5533 

 

License Agreement  

This License Agreement (the “Agreement”) is an agreement concluded between You, Your 
place of business and Blackrock. Please read the terms of this Agreement carefully following 
the link below. By downloading, accessing, saving or using Blackrock’s Software or any part of 
it, you agree with this Agreement.  If You do not agree to any term hereof, quit downloading, 
accessing, saving or using the Software and all its components already downloaded or saved 
and note that You do not have any right to Use the Software. 

 

License Agreement: http://blackrockmicro.com/neuromotive-software-license-
agreement/ 
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